Browse Source

issue #182 #178 Fix issue with scripst after moving to CMAKE_INSTALL_BINDIR

nometajit
Dibyendu Majumdar 1 year ago
parent
commit
31c64d6bb8
3 changed files with 10 additions and 10 deletions
  1. +2
    -2
      ravi-env.bat.in
  2. +3
    -3
      ravi-env.linux.sh.in
  3. +5
    -5
      ravi-env.osx.sh.in

+ 2
- 2
ravi-env.bat.in View File

@ -1,4 +1,4 @@
set RAVI_HOME=@CMAKE_INSTALL_PREFIX@
set PATH=%RAVI_HOME%\bin;%PATH%
set PATH=%RAVI_HOME%\@CMAKE_INSTALL_BINDIR@;%PATH%
set LUA_PATH=%RAVI_HOME%\share\lua\5.3\?.lua;%RAVI_HOME%\share\lua\5.3\?\init.lua;.\?.lua;.\?\init.lua
set LUA_CPATH=%RAVI_HOME%\bin\?.dll
set LUA_CPATH=%RAVI_HOME%\@CMAKE_INSTALL_BINDIR@\?.dll

+ 3
- 3
ravi-env.linux.sh.in View File

@ -1,5 +1,5 @@
export RAVI_HOME=@CMAKE_INSTALL_PREFIX@
export PATH=$RAVI_HOME/bin:$PATH
export LD_LIBRARY_PATH=$RAVI_HOME/lib:$LD_LIBRARY_PATH
export PATH=$RAVI_HOME/@CMAKE_INSTALL_BINDIR@:$PATH
export LD_LIBRARY_PATH=$RAVI_HOME/@CMAKE_INSTALL_LIBDIR@:$LD_LIBRARY_PATH
export LUA_PATH="$RAVI_HOME/share/lua/5.3/?.lua;$RAVI_HOME/share/lua/5.3/?/init.lua;./?.lua;./?/init.lua"
export LUA_CPATH="$RAVI_HOME/lib/?.so;$RAVI_HOME/lib/lib?.so"
export LUA_CPATH="$RAVI_HOME/@CMAKE_INSTALL_LIBDIR@/?.so;$RAVI_HOME/@CMAKE_INSTALL_LIBDIR@/lib?.so"

+ 5
- 5
ravi-env.osx.sh.in View File

@ -1,6 +1,6 @@
export RAVI_HOME=@CMAKE_INSTALL_PREFX@
export PATH=$RAVI_HOME/bin:$PATH
export DYLD_LIBRARY_PATH=$RAVI_HOME/lib:$DYLD_LIBRARY_PATH
export RAVI_HOME=@CMAKE_INSTALL_PREFIX@
export PATH=$RAVI_HOME/@CMAKE_INSTALL_BINDIR@:$PATH
export DYLD_LIBRARY_PATH=$RAVI_HOME/@CMAKE_INSTALL_LIBDIR@:$DYLD_LIBRARY_PATH
export LUA_PATH="$RAVI_HOME/share/lua/5.3/?.lua;$RAVI_HOME/share/lua/5.3/?/init.lua;./?.lua;./?/init.lua"
export LUA_CPATH="$RAVI_HOME/lib/?.dylib;$RAVI_HOME/lib/lib?.dylib"
export LUA_CPATH="$LUA_CPATH;$RAVI_HOME/lib/?.so;$RAVI_HOME/lib/lib?.so"
export LUA_CPATH="$RAVI_HOME/@CMAKE_INSTALL_LIBDIR@/?.dylib;$RAVI_HOME/@CMAKE_INSTALL_LIBDIR@/lib?.dylib"
export LUA_CPATH="$LUA_CPATH;$RAVI_HOME/@CMAKE_INSTALL_LIBDIR@/?.so;$RAVI_HOME/@CMAKE_INSTALL_LIBDIR@/lib?.so"

Loading…
Cancel
Save